Saxs15ID – Software for acquiring, processing and viewing SAXS/WAXS image data at ChemMatCARS

David J. Cookson (AS/ASRP/CARS)
Revised: December 07
# Table of Contents

Part 1: Getting started with saxs15id
   1.1 Installation: ................................................................. 3
   1.2 Files read in and used by saxs15id: .................................. 3
   1.3 Files written by Saxs15id: ............................................... 3
   1.4 Typical analysis sequence ........................................... 4

Part 2: The main window of saxs15id
   2.1 Main menu & file info: .................................................. 5
   2.3 2D image display area: .................................................. 7
   2.4 1 D Profile display area: ................................................ 8

Part 3: Profile normalization and calibration
   3.1 Introduction - Normalization of SANS Profiles .................... 9
   3.2 Selecting an optimum exposure time: .................................. 12
   3.3 Absolute cross section calibration using pure water ............. 13

Part 4: Camera and Detector Parameters
   4.1 Q-range window (DATA → Q-Range) .................................. 16
   4.2 Detector Parameters window (DETECTOR → Q-Range): .......... 18
   4.3 Detector mask setup (DETECTOR → Detector Masks): .......... 21

Part 5: Processing multiple SAXS profiles
   5.1 Introduction ................................................................. 23
   5.2 Main Series Window (FILES → Process SAXS Image → Image Series) ................................................... 23
   5.3 Process SAXS images menu ............................................ 24
   5.4 View Data Menu ............................................................ 25
   5.5 Output Data Menu .......................................................... 26

Part 6: Displaying and converting SAXS images (TOOLS → Output images)
   6.1 The Q-Range Window (Q-Range) ........................................ 27
   6.2 Output Images .............................................................. 28

Part 7: Spatial Correction of 2D X-ray images (DETECTOR → Spatial Correction)
   7.1 The Spatial Correction Window (DETECTOR → Spatial Correction): ................................................... 28

Part 8: Using AutoProcess (OPTIONS → AutoProcessing → Configure)
   8.1 Using the Move Expose Window (Acquire → Move Expose): .... 30
   8.6 Using the “Auto” option for Exposure time: ....................... 39
   8.7 The Aquire Setup Window (Acquire → Setup): .................... 40
   8.8 The User PV Setup Window (Acquire → User PVs): .............. 41

Part 10: Summary of Top Menu Bar Commands .................................. 42

Appendix A - Absolute calibration using glassy carbon ............... 46

Appendix B – Making SAXS/WAXS intensity maps ....... 50
   B.1 Introduction – The importance of the log file: ...................... 50
   B.2 2D scattering region of interest (ROI) (DETECTOR → Detector Masks): ................................................... 51
   B.3 1D scattering region of interest (ROI) (FILES → Process SAXS Image → Image Series): ................................. 52
   B.4 Viewing the ROI map ..................................................... 53

Appendix C - Making Thumbnail Mosaics (TOOLS → Output Images)
   C.1 Defining region of image to thumbnail: .............................. 54
   C.2 Composing the mosaic – sequentially or position mapped: .... 55

Appendix D – Calculating and applying a detector tilt correction
   D.1 Definition of tilt and tilt azimuth ..................................... 57
   D.2 How you know you have detector tilt ................................ 57
   D.3 Correcting for tilt on subsequent integrations: ................... 59
Part 1: Getting started with saxs15id

1.1 Installation:

The distributed version of saxs15id requires the freeware Virtual Machine version of IDL 6.0. Note that IDL 6.0 Virtual Machine can be downloaded for free from the web site: www.rsinc.com

The file ‘saxs15id.sav’ contains everything required to run (assuming you have installed IDL 6.0 VM correctly) but has only been tested on PC platforms. Time will tell, if this software will run on other platforms such as Macintosh.

Once you have installed the IDL 6.0 VM run time environment, start it by one of the following methods:
   a) Start IDL 6.0 VM, then select the file ‘sax15id.sav’ when prompted
   b) Create a shortcut to IDL 6.0 VM using the following target:
      C:\RSI\IDL60\bin\bin.x86\idlrt.exe -vm= <your directory path>\saxs15id.sav

This software is under constant development. At the time of the last update of this documentation the version is 3.15 – sad to say this documentation still lags behind…

1.2 Files read in and used by saxs15id:

1. Log file (filename format = *.log - eg pep1p5.log) – is an ascii file that contains normalization data for all SAXS image files and must reside on the same directory as the image files to be processed.
2. Parameter file (filename format = *.sax - eg Pep1p5.sax) – is an ascii file that contains all the camera information (beam center positions, camera length, wavelength etc) and should also be kept on the same directory as image files.
3. image.xxx – image files from CCD camera. These files should have a three digit numerical extension (eg. pep.001, pep.002 etc) and need to occupy the same subdirectory as the log file.
4. Spatial Correction File (filename format = *.spa) – are binary files containing spatial correction data for specific detectors. These are not normally required as most CCD detectors are capable of outputting image files that have already been unwarped to correct for spatial distortion.

Important Note: The best way to ensure that no confusion arises is to ensure that:
   1. Only one Log (*.log) file exists on a subdirectory - essential
   2. Only one Parameter (*.sax) file exist on the subdirectory – desirable

1.3 Files written by Saxs15id:

1. Parameter (*.sax) file. Using Data ➔ Save Saxs Params you should save the camera parameters as often as you change them.
2. Profile data (*.dat) files are ascii files containing the Q, d-space, 2Theta or Pixel value versus Intensity (and Intensity error) values. This file can be easily read into spreadsheet or data analysis packages such as IGOR.

3. 2D Excel-compatible ascii files (space delimited) for output of large numbers of processed image profiles.

4. Postscript (*.ps) output files with a printable version of the profile plot screen.

5. Image files (TIFF, PNG etc) of 2D images and output plots.

1.4 Typical analysis sequence

1. Start up saxs15id

2. Load the appropriate log file. The log file should be on the same subdirectory as the image files you intend to process.
   File → Get Scan Log

3. Load the SAXS parameter file – it should ideally reside on the same subdirectory as the previously loaded Log File.
   File → Get SAXS Parameters

4. Load the SAXS image files to be processed. If only one file is to be used for the integration use:
   File → Process SAXS Image → Single Image

5. Cosmic rays or spontaneous nuclear decays in the CCD fiber couplings can result in very intense pixel ‘zingers’ in an image. This produces spikes in the 1-D SAXS profile. One way around this problem – and to improve the effective dynamic range of the detector is to do a correlated average of several images.
   File → Process SAXS Image → Average Images


7. When the desired combination of profiles is displayed, the data can be written to an ascii data file – complete with error data.
   File → Save Profiles → N Profiles to 1 File

8. If desired, a printable version of the profile plots can be generated in the form of a postscript file. File → Print Profiles
Part 2: The main window of saxs15id

2.1 Main menu & file info:

This region shows all the files currently being used by the software including the current log file (*.log), current camera parameter file (*.sax) and the name of the image file from which the profile in the currently selected profile channel was derived. Note that the ‘Next Frame to Acquire’ field is only relevant when in SAXS control mode.

2.2 1D Profile display control:
Current Read In: shows the profile channel that is currently selected. Information shown in other areas of the main screen such as incident counts, time stamps etc all pertain to the current read in channel. Note that only one channel can be selected as current at any one time.

Current Plotted: shows the profiles that are viewable. In the profile display area numbers are matched in color to the profile traces to show which profile belongs to which channel.

Blank Subtractor: a check mark in this box indicates that the profile shown in this channel is to be subtracted from every profile in subsequent channels up to but not including the next channel to have its ‘Blank Subtractor’ box checked. In the example above, the ‘Blank’ Channel is subtracted from the profile in channel 1, while the profile in channel 2 is subtracted from both channels 3, 4 and 5. Channel 5 is the currently selected channel – the plot range is adjusted automatically to specifically accommodate this profile.

Extension Number Slider: this allows the user to easily pick an arbitrary image file extension number to read in. Moving the slider along to select a different extension number will cause the image with that extension number to be read in, integrated and the 1-D profile displayed in the currently selected channel.

Blank Channel: this is the ‘zero’ channel and differs from the other ten channels in two respects:

1. It can not have another profile subtracted from it
2. It does not get written to the ascii data output file when the user decides to save the 1-D profiles.

Zoom Plot In/Out: Hit the ‘In’ button, then left click the mouse cursor to mark on top left and bottom right corner of the region of interest. Double click on top of single peak to fit a Gaussian profile – but make sure that it is the only peak in the displayed range – otherwise strange fits will result.

Lin/Log: Hitting this button toggles linear/log scales on x and y axes.

Hold/Cycle: When set to cycle the “current channel” will increment to one every time a new image is processed, either from the FILE menu, by movement of the slider.
bar, or the acquisition of a new image (when using Saxs15id to control the instrument). This is nice when collecting or screening lots of images, but is REALLY irritating when you forget about it and are trying to do detailed image manipulations and comparisons.

2.3 2D image display area:

This area shows the raw (de-warped) image that was stored to disk from the CCD detector. Solid white lines show areas that have been masked off from the integration area – default masked areas include the outer perimeter of the image, and the beam stop area (including beam stop connecting arm).

In order to define a mask you need to select the Detector → Detector Mask option from the main menu area. The dotted lines indicate the vertical and horizontal distances represented by $Q = 0.00, 0.01$ and $0.10 \text{ Å}^{-1}$.

Note that this image is only refreshed when a SAXS image is read in and processed. Simply changing the current selected channel will not refresh this window. Note that in the “standard” Saxs15id setup only one complete raw 2-D image is held in memory at any one time.
2.4 1 D Profile display area:

The panel to the left of the profile plotting area holds the raw normalization data for the currently selected channel – in this case channel 5 (see above). This data is taken from the log data file stored in the same directory as the raw SAXS image files. These counts are the total integrated counts over the exposure time shown.

Note that these numbers are used to calculate an effective scaling factor for each profile, which allows the different profiles to be compared and/or subtracted. **When comparing (or subtracting) two different profiles, every effort should be made to ensure that both were collected with the same exposure time.**

If you must compare two profiles taken with different exposure times – you can use the ‘manual adjustment fields’ (multiplicative and additive) in the Data → Normalization menu. Another option is to use an **absolute calibration** (see below), which will put all profiles on a reasonably equal footing - irrespective of exposure duration.

It is good practice to do repeat exposures – if you can afford the time, as this allows images to be averaged and ‘zingers’ (intense spots caused by background radiation) to be removed.

**Important note about exposure times:**

**Averaging multiple shots with shorter acquire times reduces noise on profiles and avoids detector saturation in high-intensity regions, BUT will not help to resolve weak signals from the ‘inherent’ read-out noise background of the CCD detector.**
Part 3: Profile normalization and calibration

3.1 Introduction - Normalization of SAXS Profiles

See below the normalization sub-window (DATA → Normalization)

**Type of Normalization**
Usually set to “Io and Trans” which means all profiles are normalized to equal incident count rate (NOT incident counts) and equal transmission. At times, it is advantageous to ignore transmission (“Normalize to Io only”) or normalize profiles to equal count rate seen in the beam-stop x-ray detector (“Normalize to Beam Stop Intensity”).

**Counter Calibration and Blank Normalizer**
Values in these fields under ‘Counter Calibration’ are typically determined once in an experimental run. Values under ‘Abs cm⁻¹ Calibration’ may need to be calculated for every new sample holder if the specimen thickness changes. The parameters labeled A-E are as follows:

- **A)** The typical count rate for incident counts (pre-sample detector) in counts s⁻¹
- **B)** The ratio of outputs (It/Io) from the incident and transmission detectors with a ‘clear’ beam (i.e., no specimen in place).
- **C)** Factor to compensate when high-absorption samples are used. This ensures that the scale factor applied to scattering intensities is not overly inflated when normalizing a sample with low transmission.
D) Calibration factor – applied (with consideration to sample thickness) to give scattering in terms of absolute intensity (scattering cross section in cm\(^{-1}\)).

E) Calibration offset – applied when using (D)

**Auto-Calc from Clear Air Shot**

After taking an transmission measurement and a SAXS exposure of the system with nothing in the beam (no sample etc) we can hit this button to set the counter calibration parameters (like A and B). Make sure that the ‘Current Profile’ selector is on the clean air profile.

**Why normalize the integrated SAXS profiles?**

When subtracting a sample blank profile (e.g., a capillary filled with pure water) from a sample profile (e.g., nanoparticles suspended in pure water) it is important to correct for the effects of absorption. The figure below shows what happens when you try to compare the scattering from an empty capillary with that of one filled with water (dotted lines). Subtracting the raw empty cell pattern from the water+cell profile will give negative intensities! This is because the differences in x-ray transmission are so great between the two shots. If you normalize the plots to equal transmission (solid lines) you can see the true scattering power of water.

In addition to normalizing to equal transmission between samples, we also need to normalize to equal incident photon flux – to take account of fluctuations in beam flux over time. The fully normalized profile \(I_{\text{norm}}(q)\) is related to the raw profile \(I_{\text{raw}}(q)\) by the Scale Factor as:

\[
I_{\text{norm}}(q) = \text{Scale Factor} \times I_{\text{raw}}(q)
\]

\[
\text{Scale Factor} = \frac{A}{N_{0\text{Sample\(\text{cnts}\)}}} \cdot \frac{B}{N_{T\text{Sample\(\text{cnts}\)}}} \cdot C
\]
Where $N_{0\text{ sample}}$ are the counts from the flux detector prior to the sample collected over $t_{\text{exp}}$ seconds, and $N_{T\text{ sample}}$ are the counts seen by the transmission detector behind the sample for the same counting period. The global normalization constants $A$, $B$ and $C$ are as described in the previous section. They are ‘global’ in the sense that they are constant until major parameters (like x-ray energy) are changed.

**Absolute (cm$^{-1}$) Calibration**

It is important to note that the previously-described normalization will not overlay patterns taken with different exposure times. When the calibration under ‘Absolute cm$^{-1}$ Calibration’ control is set to “Use” each profile is now displayed in terms of absolute scattering cross section.

Profiles measured of the same material for different times should overlap exactly. The absolute intensity $I_{\text{abs}}(q)$ is given by:

$$I_{\text{abs}}(q) = \text{Abs Scale Factor} \times \left[ I_{\text{Raw}}(q) - E \right] \text{ (cm$^{-1}$)}$$

$$\text{Abs Scale Factor} = \frac{A}{N_{0\text{ Sample}}(\text{cnts})} \cdot \frac{B}{N_{T\text{ Sample}}(\text{cnts})} \cdot \frac{1}{N_{0\text{ Sample}}(\text{cnts})}$$

The parameters D and E can be derived using a known intensity standard and the calibration window (hit “Calculate from Standard” button) which gives:

See section 3.3 and appendix A for detailed instructions for generating absolute calibration parameters from a solid secondary intensity standard (glassy carbon).
3.2 Selecting an optimum exposure time

Question: Why not normalize all profiles to constant exposure time right from the start? Why wait until we have an absolute cm\(^{-1}\) scale?

Excellent question! When we normalize to monitor or beam stop detector counts, profiles collected with different exposure times should not overlap each other. Instead, on a log scale they will look like identical curves offset by some constant – as long as the CCD is behaving itself over the dynamic range of the profile.

The figure below shows how the scattering profile for a sample can vary depending on the exposure time. The blue trace (profile #1) shows problems at high q (low intensities) due to low scattering signal being lost in the CCD read-out noise. The magenta trace (profile #9) shows clipping due to saturation of the CCD at low q (high intensities). Somewhere in between these extremes lies the most reliable data – in this case 5-10 seconds exposure (ie. profiles #5 and #7).

By displaying the profiles normalized to constant transmission, constant incident count rate but not total incident counts we can easily see the effects of the CCD dynamic range limitations.

The three most important questions to ask about your SAXS measurements:

1) Is the final measurement linear over the entire measured q-range?
2) Is the final measurement linear over the entire measured q-range?
3) Is the final measurement linear over the entire measured q-range?
3.3 Absolute cross section calibration using pure water:

If one has collected a water profile at about 23 degrees C with a capillary identical to the one used for the real samples, it should be possible to apply it as a secondary standard to obtain an absolute cross section in cm$^{-1}$. In this case the “Standard Thickness” and “Sample Thickness” will be the same – assuming the sample holder is held rigidly between measurements.

There is only one problem with using water as a secondary standard – it is a weak x-ray scatterer. In section 3.2 the figure shows how low signal can be swallowed up in the read-out noise of the CCD chip. When combined with the large difference of transmission through an empty and water-filled cell, what looks like a decent water scatter profile may just be the noise floor of the detector artificially raised by the transmission correction.

The only way around this is to take a sequence of exposures with different exposure times for both the empty cell (blank) and the cell+water (calibrant) see below.

For the water calibrant curves the traces get closer together at higher Q. This is a classic sign that the detector read-out noise is affecting the signal.

Using the blank subtractor buttons (see section 2.2) we can take a quick look at what the different curves look like when we subtract each normalized blank profile from its corresponding calibrant profile (taken with the same exposure time).
It is fairly clear that the valid region of interest extends from about $q=0.015$ to about 0.05Å$^{-1}$. We therefore must define the q-range to make sure only this region is used in the calibration. This can be done either by zooming in on the plot region on the main window, or typing in the desired q-range at the bottom of the calibration window which is accessed via the Normalization window (Data → Normalization → Calibrate from Standard).

In the Calibration window shown below, the column on the left designates each profile channel as unused or holding data from either the blank or the calibrant. This can be changed according to what order you have processed the image files.
A quick inspection of the two curves shows that removing points by de-selecting them to ‘Unused’ status does not improve the fitted gradient error. So we should probably leave all of them in.

Once you are satisfied that all looks well in this window, you exit by hitting ‘Done’. You should see the new calibration factor and offset in the Normalization window. The user can then apply this calibration to the currently selected profile or all loaded profiles at once.

Once you ‘Use’ the absolute calibration all your data should be displayed with the same absolute scale. In the image below the blue and green lines do not overlap with those from longer exposures because of the lack of the noise floor referred to earlier.

Notes:

These line show a lot of noise – this is because the calibration was done with the longest camera length which is the most difficult and noisy water calibration to do.

The blue and green traces look really bad because they were taken with the least amount of exposure time. The longer time exposures give lines that more closely overlap when calibrated to absolute intensity.

For using solid samples like glassy carbon for a secondary absolute intensity calibrant, refer to Appendix A for a detailed description.
Part 4: Camera and Detector Parameters

4.1 Q-range window (DATA \(\rightarrow\) Q-Range)

Q-range Orientation

When measuring a sample in transmission mode it is most common to use radial integration where the q-value (momentum transfer) is a function of radial distance. For non-isotropic scatterers the integration can be done over selected azimuthal arc ranges – set in the DETECTOR \(\rightarrow\) Area Masks sub-window.

For GiSAXS measurements where intensity versus Qy and Qz profiles are desired, select one of the other orientation options. The normal to the scattering surface is established by fitting the position of a specularly reflected spot.

Q-range Binning

By selecting Geometric binning the user can get an approximately logarithmic bin size that increases with increasing q or angle. This drastically reduces the amount of points in the profile at higher q while maintaining a sufficiently fine q-spacing at lower angles. When a uniform spacing of radial distances is required, the user can use a single or double pixel linear bin.
Main Beam
Options for finding the position of the main beam:

1. **From Beam Spot:** using a high-attenuation filter and removing the beam-stop you can create a spot on the image with the main beam. The center of this spot can then be fit.

2. **Using Spot Pair:** many crystalline samples will produce a number of spots with inversional symmetry about the beam stop. Select a mirror pair and fit them.

3. **Using Ring or Arc:** the most popular way – fit a Debye-Scherrer powder ring from a crystalline powder in the beam path.

4. **From 4 sectors:** when features (powder lines or spots) are too diffuse to use, we can overlay 4 quadrant-integrated profiles. The tweak buttons “<” and “>” allow the user to jockey the center until the profiles overlap.

Whichever method is selected, after the center is found the x-y coordinates are inserted in the appropriate fields. The beam stop radius is taken as 2.5mm – and can be adjusted as appropriate. The actual beam stop radius is 2.0mm but parasitic scattering this close to the beam stop makes it practically impossible to resolve ‘real’ scattering.

Reflected Beam
Exactly the same as for the main beam. The specularly reflected spots may be much broader than a single beam burn – so the fitting box may need to be enlarged by clicking the middle mouse button and dragging out a corner.

Detector Tilt
Use this button to access the detector tilt sub-window. This allows the user to determine how far off and in what direction the detector face was tilted from the normal to the beam. The first number is the tilt (degrees) and the second the azimuth of tilt (degrees). See Appendix C for instructions how to calculate the detector tilt and apply the correction when integrating images.

Beam Stop Base
Use this to adjust the beam stop arm mask. If the beam stop mask is not enable in the DETECTOR -> Masks subwindow this is unnecessary.

Camera Parameters
Using a well-known standard such as silver behenate is an excellent way to find the exact sample to detector distance (if the wavelength is well known) or the exact irradiating wavelength if the sample-detector distance is well known. In practice, the Kohzu monochromator at ChemMatCARS is usually accurate to better than one part in one thousand - making the detector-sample distance the less known quantity.

In order to make use of the auto-adjust buttons you first need to use the main plot window and cursor to isolate and fit a single known peak from the standards scattering profile (see section 2.2 under ‘Zoom In’). Having done this, open the DATA -> Q-range window and make sure that the correct value is entered for the peak you selected (see the crib sheet
below) and hit either the ‘Adjust Length’ or ‘Adjust Wavelength’ buttons. One of the values in the two fields below should change.

**Show Coord**

Hit this button then left click a point on the image to show all the relevant q-space and intensity information.

**Level, Contrast & Zoom**: Note that Level and Contrast changes the main window image as well - Zoom does not.

### 4.2 Detector Parameters window (DETECTOR → Q-Range)

![Detector Parameters window](image)
Detector Frame Format

There are now a number of image format types supported in sax15id and more will be added at user request. All the supported types have an assumed ‘default’ set of parameters such as pixel size and number – but these can be easily changed in this window.

Note that all detector types have to have a convention for labeling sequential frames of the same series such as: image.001, image.002, image.003 etc for SMART images and image001.spe, image002.spe, image003.spe etc for Roper images. This is currently ‘hard-wired’ into each file type and can not be easily changed.

Image Corrections

For 99% of the time at ChemMatCARS frames are corrected for spatial distortion (unwarped) and corrected for linearity variations (flood and dark) prior to being saved on disk. In some cases this is not done, and must be done within saxs15id. When a blemish is found on the detector after lots of data has been collected – it can be taken out with an additional ‘remedial’ flood field correction.

Background/Dark Image

‘Load’ takes the currently loaded image in the main window and adopts it as the resident dark frame. This is multiplied by the ‘Background Scale Factor’ then subtracted from any subsequent image loaded from the File → Process Image menu prior to integration.

Flood Correction

‘Load’ opens a browser and allows the user to select a 16-bit TIFF format file. This file can be previously prepared using some of the utilities in the TOOLS → Modify Image sub-menu. Some flood field features fade with age (such as those resulting from over-exposure of the phosphor) so applying a fade factor (0< factor <1) to the flood correction often gives the best result.

Spatial Correction

This must be loaded from a special *.spa file previously prepared in the Detector → Spatial Correction sub-menu.

Median Smooth and/or Boxcar Subtraction

Allows user to change the boxcar size used for automatic smoothing and boxcar background subtraction. Ticking these options means that each 2D image upon loading is will be median smoothed and/or have a boxcar-averaged image subtracted from it prior to integration. A post-background subtraction offset can be nominated to remove any resulting negative intensity values in the image.

Time

Exposure second overhead: is an estimate of the total time in any exposure for which the counting system is counting, but no x-rays are hitting the sample. This should always be non-zero to ensure that all x-rays that hit the sample register with the Io counter and that the CCD detector is not exposed during a prior image erase cycle.
**Time Stamp**: In the case of SMART-format images, a time stamp is included in an ascii header to the image file. Usually, the time stamp for a particular image is taken from the log file – but the former case is selectable.

**Intensity**

**A/D Units per X-ray**: This is used to provide more mathematical rigor (via Poisson statistics) to the calculation of error bars for the integrated 1D profiles.

**Dark Current Offset**: To ensure that the read-out noise does not pull the intensity signal to zero or below, many detectors add a constant offset to the image prior to storing it on disk. This must be removed of course when integrating the image into a 1D profile.

Note: this is not the same as the dark image – it is a constant offset for all pixels applied irrespective of whether or not a dark frame correction is used.

**Zinger Threshold**: Averaging more than one frame to get a combined image prior to integration is an excellent way to remove the effects of zingers (intense single or multiple pixels resulting from cosmic rays or spontaneous atomic decays inside the detector light fibers). A zinger threshold of 3.0 means that if any pixel changes by more than a factor of three between two successive identical exposures – the lesser value is taken to be the correct one and then doubled. This process is also called a ‘correlated add’

**Type of Averaging**: Usually intensity at a particular radial value is taken as the average of all the pixel intensities taken within that annular ring. In some cases when the data contains some intense spots (such as when the material contains larger single grains) this can skew the intensity of a peak. In these cases it is often advantageous to use the median value instead, which will give a noisier pattern overall – but one less prone to wildly incorrect peak intensities. “Min” averaging uses the minimum value found on each constant-q annulus for the profile intensity value at that q. This can be useful when integrating what should be a azimuthally isotropic scattering patterns with a whole lot of bright artifacts (like kossel lines) which are too numerous or tricky to blank out using exclusion masks.

**Pixel Dimension**

**Number of pixel rows and columns**: This is fairly self-explanatory. Watch out when using cameras with different binning prior to image saving. Usually this is correctly set when the image is read in – but it never hurts to check.

**Pixel size**: This is a non-trivial quantity which should never be taken at face value. Remember that spatial distortion corrections can significantly change the effective pixel size of a camera. For the Bruker camera the un-warping process gives an effective shrink to the frame giving an effective size of 0.092mm – the unwarped images have an effective size closer to 0.088mm.

**Fiducial Mask**

See the DETECTOR → Spatial Correction window for more explanation of these parameters.
4.3 Detector mask setup (DETECTOR → Detector Masks)

In the example shown above, only one mask (Mask #1) has been set and defined as an including mask over the azimuthal range 56 to 86º. A cursor can be used to define arbitrary polygon shapes with vertices defined by mouse clicks. At the lower left corner more precisely-defined mask regions can be generated depending on the q-integration mode selected in the DATA → Q-range window.

For the truly masochistic, polygons can also be defined point by point with a list of coordinates on the left.

Including masks: allow the user to define the only regions that should be included in the integration. These should all be defined in a mask order before the excluding masks.
Excluding masks: allow the user to define regions that should not be included in the integration. This allows us to avoid undesirable features like zingers that have not been correlated out with multiple image averaging.

Follow Beam Center
Checking this box re-locates the corresponding circle or sector mask if the beam center position is changed in the Q-range subwindow.

Constant Qz or Qx masks
Only become definable if the Q-binning mode is in GiSAXS mode – not in normal radial q-range mode.

Notes:

1. Make sure that you are defining the correct mask. This is set in the top left corner combo box. After definition, any masks can be activated or de-activated from the top selector region at any time.

2. When defining a sector or circle mask, you must hit “Make” in order for the correct mask to appear.

3. Changing the mask configuration will (upon Applying or Exiting) re-process the image currently loaded in memory (seen in the image portion of the main window) and place the resulting profile into the currently selected channel. No previously integrated profiles will be affected. After re-defining the mask setup, all subsequent processed images will be affected.

4. The command TOOLS → Profile → Mask Sequence allows the user to produce a number of profiles from the same loaded image, using one mask at a time. Only masks defined as active (either including or excluding) will produce a profile. Profiles are displayed in separate channels.
Part 5: Processing multiple SAXS profiles

5.1 Introduction

The ability to process and display many SAXS exposures as a complete data set is one of the most powerful aspects of this software. Not only can a time-history of sample evolution be tracked, but we can also correlate different patterns against different parameters changed during the course of the experiment. These parameters are called “Positioners” and do not necessarily have to be physical translations or rotations. Other types of general ‘Positioner’ could be Temperature, Stress or Irradiating X-ray energy.

5.2 Main Series Window (FILES → Process SAXS Image → Image Series)

First Filename, Last Filename

User needs a sequentially numbered series of files in the correct current name format like: test.001, test.002, test.003… or maybe something like: test001.tif, test002.tif, test003.tif
**File Increment**

Allows user to process only every N\textsuperscript{th} profile in a nominated sequence. If this number is negative then profiles are averaged in groups of N profiles sequentially.

**Q-range scale** (horizontal axis of 2D contour plot)

Having integrated a series, user can display a subrange of q (or angle or radial pixel number). Using the “Zoom In” button allows the user to select with left click of mouse.

**Integration number** (vertical axis of 2D contour plot)

*Note that ‘Integration Number’ is NOT the same thing as the extension number on the image file name.*

As with q-range, “Zoom In” button allows the user to select with left click of mouse.

**Azimuth Sectors**

Specifies sector integration parameters (see below)

**Intensity**

Changing these parameters also changes the range parameters in the main window and vice versa. These parameters are also accessed by the zoom function on the main plot window and in DATA $\rightarrow$ Plot Range

**Normalization**

These parameters are identical to those accessed in the DATA $\rightarrow$ Normalization window

**Adjust Normalization**

This opens a window that allows the user to adjust multiplicative and offset values individually or in bulk. This also allows a user to insert single profiles constructed in the main window (current profile channel) into an existing slot in an image series.

5.3 Process SAXS images menu

**Start New Series**: erase currently stored integrated profiles and start integrating using nominated start file and end file names with file increment as shown

**Append to Series**: same as above, but append to (do not erase) currently stored profiles

**Update Series**: similar to append – but this command looks at the file name series then looks at the remaining profiles on the current directory. If there are any images which follow on from the last filename used in the currently stored profiles – it continues the sequence to the end. Very useful when analyzing a series during actual data collection.

**Truncate Series**: allows user to chop off and discard an unwanted block of integrated profiles from the end of a currently stored series. It erases all profiles starting with the next number AFTER the last number shown in the “Integration Number” range.

**Sector Integration**: works on ONLY ONE IMAGE at a time – given in the “First Filename” field. If you want to use the currently loaded image from the main window for this purpose. Use “Browse” in the first filename field and hit “Cancel”.
Cross Profile analysis  → Fit Cross Profile Ridge: Brings up a new window that allows users to fit up to four peaks (position, width and height) across an entire series of profiles. These results are saved as an ascii file which can be used later to normalize a series such that a particular peak shows constant intensity. This is particularly useful when scanning energy through an absorption edge.

![Image of peak fitting window]

User can test fit the first image in the series with peaks to see if they are being found correctly. Hitting “Fit Ridge” will then start the fit on the whole assemblage of profiles.

Cross Profile analysis  → Load, Apply, Clear Normalization: The data saved from the ridge fit command can be applied as the cross-profile normalization. It needs to be loaded first before being applied. Note that this normalization consists of N numbers – which must be identical to the number of profiles currently stored in memory.

Composite Profile  → Minimum, Maximum Envelope: Creates a single profile made up of the minimum (or maximum) values found at each q-value in series memory. This profile is stored in the currently selected profile channel in the main window. Note that this only uses the raw (un-normalized) profile data.

Composite Profile  → Average, Median Profile: Creates a single profile made up of the average (or median) value of all the profiles stored in series memory at each q-value. This profile is stored in the currently selected profile channel in the main window. Note that this only uses the raw (un-normalized) profile data.

5.4 View Data Menu

Multi-profile Contour: Gives an image as shown in section 5.1. The information on the right-hand vertical axis can be changed by checking the boxes at the middle top of the window.

Multi-profile Surface: Shows the same data as above as a single surface. Left click mouse to rotate the image around horizontal and vertical axis.
**ROI Integration Map:** Shows a 2D map correlating average profile intensity (over a nominated q-range) against experimental positioner values. See Appendix B for more information on producing these maps.

**ROI Integration Surface:** Shows map described above as a surface

**Image Options ➔:** Allows user to change display parameters

### 5.5 Output Data Menu

**Single Ascii File ➔ Profiles Only, with Errors:** All profiles over the desired q-range and an number range can be stored as a large ascii file suitable for reading into a spreadsheet program. These can be rather large. Checking the boxes at the middle top of the window includes more or less ancillary data for the profiles.

**Single Ascii File ➔ Hermans Orientation Horizontal, Vertical:** Used to output sector integration data (see above) with Hermans orientation (HOF) parameters included. Preferred axis direction either horizontal or vertical.

**Single Ascii File ➔ ROI Map Data:** Gives an ascii output showing the x,y ordinates and the intensity values produced from the ROI Integration Map.

**Multiple Ascii Files:** Outputs the same data as **Single Ascii File ➔ Profiles with Errors** but puts it in separate files – one file for each profile. User has to nominate a root file name to be used for the output files.

**Output Image as ➔ TIFF, Postscript:** Outputs the image shown in the window as a TIFF 8-bit or postscript image.
Part 6: Displaying and converting SAXS images (TOOLS \(\rightarrow\) Output images)

**Output Color Scheme**: allows output files in a range of pretty (and horrid) colors

**Output File Format**: all but the 16-Bit Tiff (T16 option) are 8-bit 3-color interleaved formats with varying degrees of information compression.

**Mosaic Image**: powerful thumbnail mosaic generator which allows thumbnails to be placed in accordance with experimental parameters used to collect the images (see Appendix B).

**Show**: toggle between a single frame (for previewing) and competed mosaic

**Save \(\rightarrow\) Current Image**: for saving single frames or single mosaics

**Save \(\rightarrow\) Image Series**: for saving frames read in with the current detector format in desired format. Note: if the pixel resolution is to be maintained upon conversion, the zoom must be set to 1
Part 7: Spatial Correction of 2D X-ray images (DETECTOR → Spatial Correction)

Spatial correction can be tricky to implement. Often this is performed internally in the detector system without the user ever having to worry about it.

When this is left for us to do, we need an image where we are very sure of what we should see so that what we actually see can be corrected in the right way. This is usually done by placing a physical x-ray mask with a regular grid of drilled holes just in front of the detector face. After irradiating the mask/detector with incident x-rays, this should give a regular grid of bright spots on the detector image. If the image shows bright spots that are not on a perfectly regular grid – we now have a way of determining the effective image distortion suffered by all exposures.

With the spot image and knowledge of real-space hole spacing and detector pixel size, we can build up a map of detector distortion – and then use this in reverse to un-distort (or un-warp) an experimental image.

7.1 The Spatial Correction Window (DETECTOR → Spatial Correction)
Spatial Correction

After calculating the complete spatial correction, the user can elect whether or not to implement it. If “Applied” all subsequent integrations are affected.

Correction Type

The correction can be derived from either a point grid pattern or a Debye Scherrer powder ring pattern (with lots of rings required). The former is much superior to the latter. In a pinch, however the latter can be used if the distortion is not too severe.

Find Fiducials

With an image full of spots – this section allows the user to accurately find and fit the spots available in the image. Once all the spots (or in the case of polar corrections – rings) have been found (in bulk and/or individually) we can then proceed to calculate the correction.

Calculate Errors

A crucial parameter in the calculation of the spatial correction equation (a 2D polynomial fit) is a good estimate of the effective pixel size of the detector. Each time a new guess for the pixel size is made the “Calculate” button shows the residual errors resulting from shifting the spots back into where they ‘should’ be on the image. This can be done with a number of iterations by answering “No” to the prompt to continue the calculation after the residuals have been plotted. Once you say “Yes” to the prompt – the calculation is completed.

Show Errors

This allows the user to see the sort of corrections that will be incorporated in the integration of the image to produce 1D profiles.

Important Note:

When the spatial correction is set as active (see above), images read in will not be automatically de-warped. This adds a few seconds to the loading of the image and is unnecessary for the production of 1D profiles – as the correction is incorporated (with zero time cost) into the integration algorithm itself.

If you want to see a warped image loaded into memory unwarped in the main image display window, you must use the command: TOOLS → Modify Image → Image Correction → Unwarp Image
Part 8: Using AutoProcess (OPTIONS → AutoProcessing → Configure)

**Procedure**: select pre-programmed batch procedure

**Parameter Ranges**: Input parameters specific to each selectable batch procedure

**Output Filename**: Use this to select which subdirectory all output data from batch procedure should be sent.

**Auto-Monitoring**
- **Polling Interval**: set the repeat time interval for checking the image subdirectory for new image files
- **Expiry Time**: image files with creation times further back than this many minutes are ignored by the monitoring program. If this value is set to zero, file age has no effect.
- **Ignore File Names with**: image files with filenames including any of these strings are ignored by monitoring program.
Part 9 : Using Saxs15id in Control Mode

9.1 Introduction

One of the most useful aspects of the Saxs15id software is the fact that it is fully integrated with the primary data collection control software at Sector 15 of the APS (ChemMatCARS). This software allows the user to collect data and do primary processing in one step. The main tasks that can be done from this software are:

a) X-ray transmission measurements of sample
b) Sample scattering images taken as single exposures or exposure sequences
c) Calibration images taken from internal standards
d) Exposure sequences taken over time or in conjunction with the movement of up to two nested positioners. A ‘positioner’ can be a motor moving the sample physically (i.e., translations, tilts, tensions etc) or an environmental variable such as temperature or irradiating energy.
9.2 Main screen of control version of Saxs15id

Most of the main screen for the control version is identical to the analysis version of Saxs15id. There are some notable exceptions as shown below:

**Next Frame to Acquire** – Naming new image files

<table>
<thead>
<tr>
<th>Field</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Test Name</td>
<td>test_112_001.tif</td>
</tr>
<tr>
<td>Max Index</td>
<td>10</td>
</tr>
<tr>
<td>Expose</td>
<td>1 sec</td>
</tr>
</tbody>
</table>

Next filename = test_112_001.tif

A new file name can be entered in this field – which is greyed out in the analysis version. The image file name has to be the correct name format for whatever CCD detector system is currently in use. When using the MAR165 detector for instance, the format of files should be Name001.tif – where “Name” is a legal string of alphanumeric characters **without spaces**.

Underscores are perfectly legal in a file name – and we encourage you to use them!

The three digits just prior to the “.tif” extension (also mandatory for TIFF - format files) are updated each time a new image is taken – eg. if the previous file name was “Name001.tif” the next filename automatically generated would be “Name002.tif”.

**Exposure** - The exposure times are chosen from a preset list of 1, 2, 5, 10, 20, 30, 40, 60, 80, and 120 seconds.

**Measurement Modes and Start Action**

Prior to starting a measurement, the user must select whether a transmission measurement, a sample SAXS exposure or a calibration SAXS exposure should be performed.

- **Transmission** : results in a single line of ascii recorded in the log file. This line is preceded with the word ‘transmission’ in the log, and contains x-ray counter data (pre and post-sample single channel detectors)

- **SAXS Exposure** : A 2D CCD image is record is acquired and stored on the same sub-directory as the currently selected log file. A single line of ascii text preceded by the file name of the CCD image is added to the log file. This line includes x-ray counter data for intensity normalization and positioner information.

- **SAXS Calibrate** : The same as for SAXS Exposure, but this also inserts a calibrant sample located at the rear of the flight tube into the beam. This is useful for locating the beam center, and calibrating beam flux.
**Start Action**: After selecting what type of measurement is to be made. The user hits this button to make the measurement.

**Stop Action**: After hitting Start Action, this button become active. The user can terminate the action up until the CCD detector starts acquiring an image. After that the user has to wait for however long the exposure time is before starting another action.

**Log Monitoring Window**

At the bottom of the main screen the log monitoring window shows exactly what information is being placed into the ASCII log file. In addition to being placed in the ascii log file, each line of log data is also placed into software memory. This data is used to normalize the plots shown in the plot region of the main GUI (see section 2.2).

![Log Monitoring Window](image)

**Test Logger** – hitting this button should result in a single line of text appearing on the bottom of the log monitoring screen. The word ‘None’ appears at the beginning of this line to show that this entry was not associated with the creation of a CCD image file. The rest of the line contains the last counter values obtained and a set of system variables that depend on what is selected in the adjacent combo box.

**Monitored Parameter Set** – one line of text in the log file is not nearly enough to record all the current experimental parameters at a particular time. The user has to choose what they want to be logged each time an image is taken. This is usually not a problem, as only up to two positioners can be changed between scans. The user changes the monitored parameter set with this combo box.

**Record Full Status** – hitting this button dumps the entire set of instrument parameters into a number of lines in the log file. It is equivalent to hitting the “Test Logger” button repeatedly while selecting each parameter set in the adjacent combo box.

**Note**: When the combo box is set to “User Defined PVs” a set of user-definable process variables is logged. This list can be changed from the Acquire setup menu (see below).
9.3 What goes on during different measurement modes

The figure shown below shows the different parts of the 15-ID-D camera affected by the different measurement modes.

![Diagram of different parts of the 15-ID-D camera](image)

The areas outlined in pink are all remotely actuated elements. Elements B through E are all located and moved inside the evacuated flight tube. These elements are controlled by Saxs15id as follows:

A) **Sample Stage** – (outside front window of flight tube) samples can be translated, tilted, stretched and heated before, during and after the collection of SAXS data. See section 10.4 below on the Move Expose Window.

B) **Alignment mirror** – (front end of flight tube) usually in when visually inspecting irradiated region of sample (from behind), this is automatically removed by the software for all x-ray measurements.

C) **Transmission detector** - (front end of flight tube) this is a PIN diode attached to the same arm that holds the alignment mirror. When doing “Transmission” measurements this is moved by the software directly behind the sample. For “SAXS Exposure” and “SAXS Calibrate” this is moved clear of the transmitted and scattered beam.

D) **Calibration Stage** - (back end of flight tube) this stage holds a number of different calibrant samples. The most commonly used one is a solid piece of mesoporous silica, which gives a very strong ring pattern when irradiated with the direct beam during a “SAXS Calibrate” action. For normal SAXS exposures, this stage (which also has a PIN diode attached to assist with camera alignment) is moved clear of the direct and scattered beam.

E) **Beam Stop** - (back end of flight tube) the beam stop has an embedded PIN diode which is useful for alignment and backup transmission measurements. Its position can be scanned by the software, but in practice never is.
9.4 Using the Move Expose Window (Acquire → Move Expose)

The “Move Expose” window allows users to set up multi-exposure runs that can change the position or environmental state of a sample and take one more exposures at each point. During such an exposure sequence the file names of the saved images all have the same root but are incremented in numerical extension (e.g. `test001.tif, test002.tif, test003.tif` etc).
Exposure Setup

Name of Frames: The root name of the files to be saved can not be set from the Move Expose window – only from the main screen (section 10.2).

Exposure Time: This is identical to the exposure time selection box on the main screen and can be changed in either screen.

Wait Between(s): Allows the user to specify a wait time in seconds between exposures. This is useful when doing a time series of measurements where a system is evolving slowly.

Starting Number: Like the root file name, this must be set from the main window.

Positioner 1 Control area

Positioner Selector: A wide range of positioner elements are selectable. In addition to being able to scan sample translation, tilt, stretch, temperature and irradiation energy, the users can also move beam delivery optics like x-ray slits. This is useful for optimizing different delivery optics to minimize parasitic scatter etc.

Note: When selecting a positioner, the value to the right of the combo box contains the current positioner value. There are times when this is not always refreshed to current value. To ensure that it does contain the current value re-select the positioner you want in the combo box.

Move to this ➔: User can enter a new value for the positioner in the field to the right of this button (Home) then hit the button to send the positioner there. Moving each positioner is usually done from other screens (MEDM screens) but can be done here as well.

Home +: Contains the lower extreme of any scan range for the positioner. This quantity is added to the value shown to the left of the “Move to this ➔” button.

Home -: Contains the upper extreme of any scan range for the positioner. This quantity is added to the value shown to the left of the “Move to this ➔” button.

N pnts: Contains the number of points that will be used in the scan between the “Home −” and “Home +” extremes. An odd number here ensures that the middle point of the scan will fall on top of the current home position.

Import and Start: see below for explanation
Positioner 2 – Outer Loop Controller

The control area for positioner 2 is exactly the same as for positioner 1. If Positioner 1 had “Sample_X-pos” selected and Positioner 2 had “Sample_Y-pos” selected, then a 2D scan would see multiple increments of x position for every single increment of y position.

Positioner 1 & 2 Tables

The values shown in these tables are generated as soon as return is hit in the “Npnts” field. In this case five points were generated between the two extremes of home position +/- the minimum and maximum extremes.

Note that these values can be manually edited – although care has to be taken not to overwrite them (by hitting return in the “Npts” field)

Link between Pos 1 & 2

Selecting Grid : With 5 ordinates in the Pos1 table and 6 ordinates in the Pos2 table, a grid nesting Pos1 inside of Pos2 will give a total of 30 positions.

Selecting Trajectory : This will give 5 positions with coordinate pairs (Pos1,Pos2) shown in rows 0 to 4. Note that if the number of listed ordinates is different for Pos1 and Pos2, whichever ordinate list runs out first defines the total number of coordinate pairs measured.

PV Monitor Set : Identical to the combo box selector in log line section of the main screen, this allows the user to define what set of experimental parameters is logged with each exposure taken. Changing the Positioner Selector automatically redefines the PV Monitored Set – but this can be overridden by using this combo box controller.
9.5 Importing a list of positioner ordinates

*Import*: There are times when an evenly spaced set of ordinates is not appropriate – this renders the positioner control area (where ranges are set and numbers of points are specified) useless. Under these circumstances it is necessary for the user to define each position by editing the Pos1 and Pos2 tables by hand.

This can be very onerous – and it is a much better idea to import a list of ordinates directly from two ascii files one for the Pos1 table the other for the Pos2 table.

The format used for these ordinate position files is a single column (ie one number per row) of numbers. The first number is an integer corresponding to the total number of floating point numbers to be read into the software. Subsequent numbers are floating-point positioner data values that do not have to be monotonically spaced. The sign of the first integer in the ascii data file is also important:

**Positive integer**: as first number in ordinate data file: all values in ordinate data file are absolute and are fed directly into the corresponding Pos1 or Pos2 table.

**Negative integer**: as first number indicates that all subsequent ordinate data values are relative to the designated home position (number in field to the right of the “Move to this” button).

Examples of importable positioner ordinate file (Home = 1.0)

<table>
<thead>
<tr>
<th>Ordinate File</th>
<th>Pos(1or2) Table</th>
<th>Ordinate File</th>
<th>Pos(1or2) Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>5</td>
<td>1.1</td>
<td>-5</td>
<td>1.1</td>
</tr>
<tr>
<td>1.1</td>
<td>1.3</td>
<td>0.1</td>
<td>1.3</td>
</tr>
<tr>
<td>1.3</td>
<td>1.7</td>
<td>0.3</td>
<td>¬1.7</td>
</tr>
<tr>
<td>1.7</td>
<td>1.9</td>
<td>0.7</td>
<td>1.9</td>
</tr>
<tr>
<td>1.9</td>
<td>2.1</td>
<td>0.9</td>
<td>2.1</td>
</tr>
<tr>
<td>2.1</td>
<td></td>
<td></td>
<td>1.1</td>
</tr>
</tbody>
</table>

**Starting a trajectory or grid scan mid-way through**

Using the *Start* field (right next to the “N pts” field) the user can start a scan at some intermediate point. This is most useful when you want to repeat some portion of the scan without having to re-calculated a new scan range or trajectory. A number in this field will correspond to a row number in the corresponding Pos 1 or Pos 2 table.
9.6 Using the “Auto” option for Exposure time

It is often difficult to know exactly what exposure duration is best when measuring a series of SAXS exposures. Too long and you saturate the detector, too little and weak scattering signal is lost in the detector noise floor. It is also sometimes useful to take transmission measurements just before every SAXS exposure in a series.

To enable the user to take several exposures at each position in an exposure series we can make use of the “Auto” exposure time option (choose “Auto” instead of an explicit exposure time like “10sec”).

In the Acquire Setup Window (see ACQUIRE → Setup below) an exposure batch command line becomes enabled when the exposure time is set to “Auto”.

The code used is fairly straightforward – each action is separated by a comma:
“t” means take a transmission measurement (time for counting given in the field below)
“eN” (N = 1, 2, 5, 10, …240) means take a regular exposure for N seconds
“cN” (N = 1, 2, 5, 10, …240) means take a calibration exposure for N seconds

Notes:
1) When using the “Auto” option, every ‘position’ in a scan will result in multiple exposures. In a long scan (say 30x30 raster points) this will result in 900 positions times the number of exposures at each position which quickly exceeds the maximum number of exposures in a series of 999.
2) Taking a transmission (ie using “t” in the Auto expose batch line) adds considerable time overhead to a multi-position measurement, as this requires mirrors/detectors to be continually moving in and out of position. Typically adding a transmission measurement will add 30 seconds of time to a scan for every transmission measurement made.
9.7 The Acquire Setup Window (Acquire → Setup)

Introduction

When controlling the SAXS camera at 15ID with Saxs15id software, a lot of care has to go into setting up the system for whichever CCD detector system is available on the day.

A number of CCD detector systems can be made to work with this software – the most well suited being the MAR-165 system. Whatever CCD system is used, there will always be a computer associated with the detector which needs to be interfaced with Saxs15id and to other computers on the network.

In the case of the MAR-165 system an EPICS-based system (written by Mark Rivers – Sector 13) is used to communicate between the network and a dedicated Linux server attached to the actual detector.

Acquisition Times

As explained in the previous section, the “Auto” option for exposure time allows for a batch line to be executed at each measurement position.

CCD Directory Setup

Frequently the images coming from the CCD system will need to be saved on a separate file system. These images are then accessed by Saxs15id for subsequent processing. It is highly likely (especially when mixing Windows and Linux machines) that the path names required by each server to point to the same physical data will be different.

Browse : Allows the user to find the correct data directory from the point of view of Saxs15id

As seen from CCD server : allows the user to prepend as much of a different path name as necessary to allow the CCD server to find the same subdirectory.

CCD Software Settings

Initialize : Tells the CCD system to acquire a dark current, reset offsets, and generally clear its mind. This is good to do reasonably often as dc offsets can drift – giving slightly different intensity values for identical exposures.

CCD Chip → xsize, ysize : these are specific to a particular CCD system

→ Bin: this can usually be set to a limited range of values (usually 2 or 4).
9.8 The User PV Setup Window (Acquire → User PVs)

The user can define up to two positioners (ie parameters that can actually be driven automatically by Saxs15id). These are then selected as Positioners: “User Def 1” and “User Def 2” in the positioner selector boxes in the Move Expose Window.

The user can also define up to five other parameters to be read and added to a log file entry (one line), associated with a transmission or exposure event.

The “Test” button allows the user to confirm that the process variable (PV) name is correct and the system is working. If all is well, a value should appear (instead of the “xxxxxx” next to the parameter row).
Part 10: Summary of Top Menu Bar Commands

FILE ➔ Process SAXS Image

➔ Single Image: process a single image file and produce a single 1D profile which is placed in the current selected channel. Profile is normalized to either incident or beam stop counts and calibrated according to the settings in the normalization window (see DATA ➔ Normalization)

➔ Average Images: process a sequence of image file and produce a single averaged 1D profile. This profile is treated exactly the same as for a single image

➔ Image Series: brings up Series Window and allows user to integrate a large number of images, then display them as a 2D color image.

FILE ➔ Get Scan Log:

Input the scan information for a group of images. The software assumes that any images that the user wishes to process will be on the same directory as the log file. The log file must have the extension ‘log’ eg. Day 1.log

FILE ➔ Get SAXS parameters:

The parameter file must have the extension ‘sax’ eg. Day 1.sax This file contains all the information pertaining to a particular camera configuration (length, beam center, wavelength etc).

FILE ➔ Save Profiles:

➔ Nprofiles ➔ 1 File: Output all profiles shown in the main window plot region to a single Ascii file.

➔ Nprofiles ➔ N Files: Output all profiles shown in the main window plot region to N Ascii files with root name supplied by user. Note that the channel number will be appended to this root name.

➔ Print Profiles Image Color, B&W: Output all profiles shown in the main window plot as a postscript image.

➔ Save Profile Summary: Output ascii file with all pertinent parameters used to calculate profiles (normalization, calibration data etc)

➔ Save Complete Session: Output entire session and allows it to be restored later. This produces a large (~10Mbyte) binary file and must be used with care. The extension of the session save file must be “.sav”.

FILE ➔ Import Profile:

Imports a profile saved as an ascii file (3 columns: q, I and error). It coerces the imported q-range using interpolation so that the saved profile (put in the currently selected channel) has q-values exactly the same as the other profiles in memory. This requires other properly-processed profiles to actually be present in memory.

FILE ➔ Clear All Profiles:

Reset the right hand selector buttons and clear all profiles from memory.
FILE ➔ *Restore profiles/session*:

Restores a previously saved session (*.sav file).

*Note: ACQUIRE menu options are only available when in SAXS control mode.*

ACQUIRE ➔ *Setup*:

Opens setup window that allows interfacing of control version of Saxs15id to the current area detector and distributed servers.

ACQUIRE ➔ *User PVs*:

Opens user PVs window that allows monitored and controlled experimental positioners to be defined.

ACQUIRE ➔ *Move Expose*:

Opens Move-Expose window that allows the automatic acquisition of SAXS data whilst moving experimental positioners (such as sample translation or temperature).

TOOLS ➔ *Log File*

➔ *Display Current*: Handy for checking out the current log file.

➔ *Summarize Current*: Similar to above, but summarizes the log file for quick checking.

➔ *Override Log File*: Allows user to modify in-memory log data. This is useful if there was some systematic mistake in the logged data. This command also allows a pseudo-log file to be generated when no log data file is available.

TOOLS ➔ *Frame Header*

➔ *Display Current*: Shows the header data of most recently read in file.

➔ *Summarize Series*: Shows the frame file info for specified sequence of image files (ie. name, creation time, file size).

TOOLS ➔ *Modify Image*

➔ *Median Smooth*: replaces current frame in memory with a median smoothed image, box size changed in DETECTOR ➔ Frame Parameters window. **Warning!** A median smooth with a box size greater than 3 can take a long time.

➔ *Boxcar Smooth*: replaces current frame in memory with a boxcar average smoothed image, box size changed in DETECTOR ➔ Frame Parameters window.

➔ *Boxcar Standard Deviation*: replaces current frame in memory with a standard deviation image using the same box size as the boxcar smooth.

➔ *Subtract Boxcar Average*: replaces current frame in memory current frame minus the boxcar smoothed frame. An offset can be added to prevent negative intensity values.
→ **Normalize Image** → **To Io, Ibs**: replaces current frame with image normalized according to either the Io or Ibs counts found in log file. This is usually done AFTER integrating the image to make a 1D profile.

→ **Image Correction** → **Unwarp Image**: applies spatial correction to frame in memory – replacing it with an unwarped image. The spatial correction is generated in a separate window DETECTOR → Spatial Correction

→ **Image Correction** → **Fix Sector Offsets**: 4-sector CCD readouts sometimes give slightly different DC offsets to the image (giving a 2x2 patchwork effect). This can be corrected by tweaking controls in this window.

→ **Image Correction** → **Insert ROI to Current Frame** → **Cut/Paste to ROI**: Using masks defined as including in the DETECTOR → Area Masks window, the use can cut out a region from a frame on disk and insert (overlay) it on top of the image currently in memory.

→ **Image Correction** → **Insert ROI to Current Frame** → **Average Outside ROI**: As above but the inserted area of image now has pixel intensities that are an average of the disk image and the resident image.

**TOOLS** → **Generate Image**

→ **…From Current Profile**: The profile in the currently selected channel is swept about the beam center to create an artificial 2D isotropic pattern.

→ **Pseudo Flood Field**: Create a flood correction frame by dividing a swept pattern with the actual pattern. This can work quite well to remove a well-localized blemish caused by a ‘bleached’ region of CCD phosphor.

→ **Power Law Pattern**: Create an isotropic pattern with an intensity drop off given by the power law \( I = Aq^p \) where the power law exponent \( p \) is specified in the DATA → Plot Range window.

**TOOLS** → **Profile**

→ **Algebraic Manipulations**: Opens a window that allows algebra to be performed on channel profiles with the results saved in other channels.

→ **Azimuthal Arc**: Using the currently defined q-range, an annular ring is integrated radially with and displayed as intensity versus azimuth angle on the main plot window along with some key parameters.

→ **Consolidate**: All profiles that are currently visible (ie have their ‘Current Plotted’ buttons checked are averaged and the resulting profile placed in the currently selected channel.

→ **Mask Sequence**: The currently loaded image is integrated according to the defined user masks. The difference here is that each user mask is applied one at a time (rather than all at once) producing one profile for each user-defined and enabled mask. Each profile is stored in a different channel.

**TOOLS** → **Counter Check**: Diagnostic tool for counters – using log file data and comparing the ratio of Io/It and Io/Ibs to check for counter drift/linearity.

**TOOLS** → **Output Images**: Window for summarizing SAXS images and constructing thumbnail mosaics (see Part 6 and Appendix B). Also useful for converting large numbers of image files from one format to another.
**TOOLS**  \(\rightarrow\)  *Preview Images*:  Similar to above, but more automated with text file summaries produced in addition to output images.

**DATA**  \(\rightarrow\)  *Plot Range*:  Window for change the plot parameters, including choosing the horizontal ordinate – pixels, 2theta, Q, d-spacing. Also allows simple peak fitting and the addition of extras (legends, high-q sloping lines etc) on the plots.

**DATA**  \(\rightarrow\)  *Q Range*:  Window for changing camera geometry parameters (camera length, beam center coordinates etc). Changing any of these parameters requires the program to re-calculate the integration setup (see section 4.1)

**DATA**  \(\rightarrow\)  *Normalization*:  Window for changing the normalization and calibration parameters for the integrated profiles (see section 3.1)

**DATA**  \(\rightarrow\)  *Save SAXS Parameters*:  Save current SAXS parameters as an ASCII file

**DETECTOR**  \(\rightarrow\)  *Area Masks*:  Window for defining and enabling inclusion and exclusion area masks for integration of data from images (see section 4.3)

**DETECTOR**  \(\rightarrow\)  *Detector Parameters*:  Window for changing image format type and associated parameters (see section 4.2)

**DETECTOR**  \(\rightarrow\)  *Spatial Correction*:  Window for generating and saving spatial correction files.

**OPTIONS**  \(\rightarrow\)  *Main Display*:  Window for changing frame display parameters in left pane of main display.

**OPTIONS**  \(\rightarrow\)  *Version Notes*:  Displays most up-to-date information on software package.

**OPTIONS**  \(\rightarrow\)  *Auto Processing*  \(\rightarrow\)  *Configure*:  Window for selecting which auto-processing features will be available, and how they will work.

**OPTIONS**  \(\rightarrow\)  *Auto Processing*  \(\rightarrow\)  *Enable AutoProcessing*:  Enables the front AutoProcess button to be used by users.

**OPTIONS**  \(\rightarrow\)  *Auto Processing*  \(\rightarrow\)  *Enable A.P. with Batch*:  Enables the front AutoProcess button to be applied automatically to a collection of image file names selected by the user.

**OPTIONS**  \(\rightarrow\)  *Auto Processing*  \(\rightarrow\)  *Enable A.P. with Monitor*:  Enables the front AutoProcess button to be applied automatically every time a new image file appears on a designated subdirectory.
Appendix A - Absolute calibration using glassy carbon

1) Ensure that images are as ‘clean’ as possible

   a) If your images are blemish-free there is no need to use a mask!

   b) If you do have some unsightly blemish (as below) we need to remove this or risk compromising the calibration (not to mention subsequent analyzed data).

   c) Using the Mask Setup submenu – you can create either including or excluding masks. These defined masks are saved when you use the DATA → Save Saxs Parameters command.

[Diagram of shadow artifact creating unwanted profile features]

Use the DETECTOR → Area Mask window to set up an excluding mask

[Diagram of excluding mask giving a better profile]
2) Make sure ‘Counter Calibration’ parameters are set properly

- Normalize with Io and transmission
- Make sure that an air profile is ‘currently selected’ - then hit this button
- After hitting Auto-calc the transmission should = 1.00 for all the air profiles

3) Load the blank and calibrant profiles

Load in both blank (in even numbered channels, starting from channel 0) and calibrant profiles (in odd channels). Using the blank-subtractor controls you can see over what part of the q-range the calibration profile is good. Note: subtracted profiles shown on linear y-scale.
Now we need to find a calibration curve for our secondary standard. This particular glassy carbon sample (thickness = 0.995mm) was called ‘Lyle’ and was measured on an absolute scale using the UniCAT USAXS instrument. This is likely to be the standard used at CMC.

### Abs cm⁻¹ Calibration

<table>
<thead>
<tr>
<th>Standard Name</th>
<th>Other</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cross Section (cm⁻¹)</td>
<td>30.7</td>
</tr>
<tr>
<td>Standard Thickness (mm)</td>
<td>995</td>
</tr>
<tr>
<td>Sample Thickness (mm)</td>
<td>995</td>
</tr>
<tr>
<td>Calibration Factor</td>
<td>1</td>
</tr>
<tr>
<td>Calibration Offset</td>
<td>0</td>
</tr>
</tbody>
</table>

4) **Using ‘Calibrate from Standard Window’**
a) Make sure that the q-range shown on the bottom of the window corresponds to the correct region of the scattering profile. The profile intensity over this region must average out to whatever value you select for the Cross Section (cm⁻¹) field in the main Normalization window.

b) Make sure that the blank and calibrant profiles are correctly designated on the left hand side of the screen. If points from shorter exposure time appear to reduce the quality of line fit they can be removed by checking the ‘Unused’ button.

c) Once you are satisfied with the fits – both the “Use” buttons can be hit to calculate the final calibration constant and offset.

5) **Apply normalization**

Before calibration y-scale of plots is displayed in arbitrary normalized units.

![Normalization Window](image)

- **Type of Normalization**:
  - Do not normalize
  - Normalize to lo only
  - Normalize to lo and Trans
  - Normalize to B-Stop Int

- **Counter Calibration**:
  - Clear beam lo c/s: 259315
  - Clear beam lbo c/s: 208679
  - Clear beam lo/lo: 1.66447
  - Auto-calc from Clear All Shot

- **Blank Normalizer**:
  - Blank Transmission: 1.00000

After calibration y-scale of plots is displayed in units of cm⁻¹.

![Normalized Plots](image)

a) Set the “Use” button

b) Apply Normalization : To All Profiles → Global Params Only. If you use the “All Parameters” option you will also apply any Manual Profile Adjust numbers you may have entered.
Appendix B – Making SAXS/WAXS intensity maps

B.1 Introduction – The importance of the log file

When using Saxs15id to collect or analyze data, you always need the log file to keep track of all the data (normalization detector counts etc) related to each exposure. On the single line devoted to each exposure, you will also see a strange-looking string such as: “SAM_X_Y_AUX_ATT_LOV” followed by a bunch of numbers that extend to the end of the line.

This string and the corresponding ancillary data can change depending on how the control program and experiment has been set up. For some clue as to what these parameters might be – go to a section of the log file where a summary dump has been placed (look for a block of text with “/#” starting each line). The last line of this block has the phrase “USER MONITORED VALUES” followed by single word descriptions of each of these values.

This ancillary information makes it possible to construct maps where single pixels of integrated SAXS intensity or small thumbnail images can be placed on a 2D grid with ordinates corresponding to positioner values which could be x, y translation, sample tilt, temperature etc. Shown below are the maps produced from 289 SAXS images taken whilst rastering the x-y position of a piece of PET polymer through the beam. By changing the q-range region of interest (ROI) we get very different looking maps.

Folding a piece of polyethylene teraphthalate (PET from a water bottle) to give 2 creases

SAXS / WAXS scattering is sensitive to the re-distribution or induction of crystalline structure
B.2 2D scattering region of interest (ROI) (DETECTOR → Detector Masks)

Before doing the series integration, we may choose to select an area mask to define regions to include or exclude in the radial integration. This can be done in the mask window (DETECTOR → Area Masks) as shown below – here we have a sector mask (-10 to 10 deg) to emphasize one sector of scatter.

With this (including) mask activated all the integrations performed in the main window or in the series window will only use pixels within the triangular area.

We can now go to the series window and set up the series integration. In this example the files pp8.001 to pp8.289 were specified by the first/last filename fields. The ancillary data string SAM_X_Y_AUX_ATT_LOV showed that the x and y sample positions were parameters 1 and 2 following the string. We therefore have to ensure that the Xord and Yord selector controls are set to 1 and 2 respectively.
B.3 1D scattering region of interest (ROI) (FILES → Process SAXS Image → Image Series)

Having processed the file in this series (using PROCESS SAXS IMAGES → Start New Series) we now have a contour map of all the profiles. Color indicates intensity on either a log or linear scale. The horizontal scale gives $q$ and is linear or log depending on how you choose to bin the pixels (see DATA → Q-Range window). On the left vertical is the integration number and on the right vertical the names of the files read to produce each profile. Checking “Scale Factor” or “Time Stamp” on the top will change what data is shown instead of file name.

Note that color schemes and other options can be changed for this window by using the command VIEW DATA → Image Options.

Now we can specify a $q$-range of interest either by using the “Zoom In” button under the Q-range scale area or by inputting the values in the fields nearby (remember to hit return after entering the values).
B.4 Viewing the ROI map

We can now view the ROI map using the command `VIEW DATA \rightarrow ROI integration map`. You can then alter the Intensity range to emphasize the map.

Another option is to view the map as a surface using `VIEW DATA \rightarrow ROI surface map`.

Things to watch out for:

1) If you get a line rather than a nice map – check that you set the ordinate values correctly.
2) Remember that when you change area masking, you need to re-integrate all the images in the series.
Appendix C - Making Thumbnail Mosaics (TOOLS ⇒ Output Images)

There are times when you want to examine how the entire SAXS pattern changes with a change in experimental parameters. For this we can use a completely different window: TOOLS ⇒ Output Images.

C.1 Defining region of image to thumbnail

Before opening the TOOLS ⇒ Output Images window, make an including mask that contains the portion of the image that you wish to tile into a mosaic. This can be done easily using the cursor option for mask definition (see below).

Note which user-definable mask you have used for this purpose (here it is mask # 1).
C.2 Composing the mosaic – sequentially or position mapped

Now go to the Output Image screen (TOOLS → Output Image) where you will see a zoomed version of the image.

You need to make a decision as to how large each tile should be. If you have lots of tiles, you need to zoom the tiles smaller, so that the maximum mosaic image size of 4000x4000 pixels is not exceeded. In this example we are zooming out (reducing) the image by a factor of 6.

Now under the Mosaic Image control region (left side of window) we can specify the sub-area of the image we wish to tile (we can select ‘full image’ if we like). Also we need to assign the x and y ordinates (as for the ROI map) – in this case we are using the sample x and y translation position.
Finally we need to select whether we want a mosaic which just shows the image tiles in order of acquisition (increasing sequence number left to right, top to bottom) OR have their position correlated to their position ordinates (as in an x,y grid). Map(nxm) and Map(scale) will both do this – the scale version will preserve a non-even aspect ratio if (for example) x and y translations were different in increment.

**Important things to note:**

1) Note that if you are using the Map (Scale) option, you may have to further reduce the size if each tile than when using the Map (n x m) option.

2) Once you have created the mosaic, it is not possible to change the contrast and level of the images – this has to be done on the single ‘preview’ tile image.

3) The single preview tile image can be seen by checking the option button under “Show” (lower left hand corner of window).
Appendix D – Calculating and applying a detector tilt correction

D.1 Definition of tilt and tilt azimuth

The figure below shows how tilt is defined as the angle between the incident main beam trajectory and the normal to the CCD detector plane. Ideally this should be zero (i.e., the detector orthogonal to the main beam trajectory).

In practice this is sometimes non-zero. The direction in which this tilt manifests is important and is defined by the tilt azimuth. This is also shown in the figure below as is defined as zero when the normal to the detector plane is tilted towards the right hand side of the detector face (as seen by the incident beam).

D.2 How you know you have detector tilt

Using the ‘Detector Tilt’ button in the Q-Range window, we get:
The image shows a powder sample (Cesium Oxide) diffraction pattern with lots of Debye-Scherrer diffraction rings. These should all be concentric (share a common center) and in an unstrained sample be perfectly circular. If the detector plane is not normal to the main beam trajectory, these rings will appear slightly elliptical, and their centers will move in a predictable way with increasing radius.

It is very difficult to accurately measure the elliptical shape of nearly-circular objects, but it is reasonably easy to measure their centers. In this software we can find the centers of up to eight concentric rings, where each ring is found by hitting the ‘Find’ button. You should start with the smallest radius ring for ‘Ring 0’ and work up with increasing radius.

The three point, left click technique for starting the fit on each ring is identical to that used when fitting the beam center using a ring or arc in the Q-range window.

Once you have a good number of rings – ideally all eight you can press ‘Calculate Tilt’ to give the plots below. This gives the best-fit tilt, azimuth and ‘true’ beam center.

If the two plots overlaying the image on the right look ok (sometimes the azimuth fit can be clearly wrong and just requires a ring to be re-fit) you then press ‘Calc. Correction’. This gives a visual check of what the correction matrix looks like (for what this is worth). One can then check the ‘Apply’ button to ensure this tilt correction is used for subsequent integrations.
D.3 Correcting for tilt on subsequent integrations

As can be seen from the cake integrations below, including the detector angle tilt correction significantly reduces the distortion of the higher angle powder rings.

Important points to note:

a) You must choose between using CCD spatial correction OR detector tilt correction – you cannot (for now) use spatial correction AND detector tilt correction simultaneously.

b) The user must have a good idea of the sample to detector distance, and the pixel size of the CCD detector as these parameters are essential in calculating the tilt.

c) If you save the SAXS parameters (DATA ➔ Save SAXS parameter) and have the tilt correction enabled (ie ‘Apply’ checked in tilt calculation window). Subsequent sessions that use this SAXS parameter file will apply this correction when integrating.